use strict;
my $str = 'Animals {
idAnimal
nameAnimal
animal456jlk165ut[name="Dalty"]
animal6ljkj[name="Moon"]
}
Animals {
idAnimal
nameAnimal
animalk45lil69lhfr5942lk[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
animalko5854hg[name="Oty"]
animalko5854hg[name="Dan"]
}
Animals {
idAnimal
nameAnimal
animalko5854hg[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
}';
my $regex = qr/{[^{}]*?\banimal(\w+)\[name="[^\s"*]*"]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}