#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$"
Local $sString = "bankofamerica.com" & @CRLF & _
"www.bankofamerica.com" & @CRLF & _
"" & @CRLF & _
"bankofamerica.co.uk" & @CRLF & _
"www.bankofamerica.co.uk" & @CRLF & _
"" & @CRLF & _
"bankofamerica.com.uk" & @CRLF & _
"www.bankofamerica.com.uk" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"bankofamerica.com.securersite.regexr.com" & @CRLF & _
"" & @CRLF & _
"bankofamerica.co.uk.blahblahblah.secure.com.it" & @CRLF & _
"" & @CRLF & _
"acklenx.com" & @CRLF & _
"www.acklenx.com" & @CRLF & _
"" & @CRLF & _
"bit.ly" & @CRLF & _
"v.gd" & @CRLF & _
"is.gd" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")