package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$`)
var str = `bankofamerica.com
www.bankofamerica.com
bankofamerica.co.uk
www.bankofamerica.co.uk
bankofamerica.com.uk
www.bankofamerica.com.uk
bankofamerica.com.securersite.regexr.com
bankofamerica.co.uk.blahblahblah.secure.com.it
acklenx.com
www.acklenx.com
bit.ly
v.gd
is.gd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}