$re = '/^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$/im';
$str = 'bankofamerica.com
www.bankofamerica.com
bankofamerica.co.uk
www.bankofamerica.co.uk
bankofamerica.com.uk
www.bankofamerica.com.uk
bankofamerica.com.securersite.regexr.com
bankofamerica.co.uk.blahblahblah.secure.com.it
acklenx.com
www.acklenx.com
bit.ly
v.gd
is.gd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);