using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$";
string input = @"bankofamerica.com
www.bankofamerica.com
bankofamerica.co.uk
www.bankofamerica.co.uk
bankofamerica.com.uk
www.bankofamerica.com.uk
bankofamerica.com.securersite.regexr.com
bankofamerica.co.uk.blahblahblah.secure.com.it
acklenx.com
www.acklenx.com
bit.ly
v.gd
is.gd
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}