const regex = /^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)\\.?(([^.]*)(?:(?:\\..{2,3})|(?:(?:\\..{2,3})(?:\\..{2}))))$', 'gim')
const str = `bankofamerica.com
www.bankofamerica.com
bankofamerica.co.uk
www.bankofamerica.co.uk
bankofamerica.com.uk
www.bankofamerica.com.uk
bankofamerica.com.securersite.regexr.com
bankofamerica.co.uk.blahblahblah.secure.com.it
acklenx.com
www.acklenx.com
bit.ly
v.gd
is.gd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}