// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$").unwrap();
let string = "bankofamerica.com
www.bankofamerica.com
bankofamerica.co.uk
www.bankofamerica.co.uk
bankofamerica.com.uk
www.bankofamerica.com.uk
bankofamerica.com.securersite.regexr.com
bankofamerica.co.uk.blahblahblah.secure.com.it
acklenx.com
www.acklenx.com
bit.ly
v.gd
is.gd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}