import re
regex = re.compile(r"^(.*?)\.?(([^.]*)(?:(?:\..{2,3})|(?:(?:\..{2,3})(?:\..{2}))))$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("bankofamerica.com\n"
"www.bankofamerica.com\n\n"
"bankofamerica.co.uk\n"
"www.bankofamerica.co.uk\n\n"
"bankofamerica.com.uk\n"
"www.bankofamerica.com.uk\n\n"
" \n"
"bankofamerica.com.securersite.regexr.com\n\n"
"bankofamerica.co.uk.blahblahblah.secure.com.it\n\n"
"acklenx.com\n"
"www.acklenx.com\n\n"
"bit.ly\n"
"v.gd\n"
"is.gd\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")