import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\.?(([^.]*)(?:(?:\\..{2,3})|(?:(?:\\..{2,3})(?:\\..{2}))))$";
final String string = "bankofamerica.com\n"
+ "www.bankofamerica.com\n\n"
+ "bankofamerica.co.uk\n"
+ "www.bankofamerica.co.uk\n\n"
+ "bankofamerica.com.uk\n"
+ "www.bankofamerica.com.uk\n\n"
+ " \n"
+ "bankofamerica.com.securersite.regexr.com\n\n"
+ "bankofamerica.co.uk.blahblahblah.secure.com.it\n\n"
+ "acklenx.com\n"
+ "www.acklenx.com\n\n"
+ "bit.ly\n"
+ "v.gd\n"
+ "is.gd\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}