# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h/_/g;t' <<< "Sit amet dolo lorem (\"lorem ipsum do olor\") dsa (\"ipsum olora dsa\")
(\" dasd adas d\")"