re = /\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h/
str = 'Sit amet dolo lorem ("lorem ipsum do olor") dsa ("ipsum olora dsa")
(" dasd adas d")'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result