$re = '/\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h/';
$str = 'Sit amet dolo lorem ("lorem ipsum do olor") dsa ("ipsum olora dsa")
(" dasd adas d")';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;