#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h"
Local $sString = "Sit amet dolo lorem ("lorem ipsum do olor") dsa ("ipsum olora dsa")" & @CRLF & _
"(" dasd adas d")"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)