import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\"[^ ]*\\K\\h|(?!^)\\G[^\" ]*\\K\\h";
final String string = "Sit amet dolo lorem (\"lorem ipsum do olor\") dsa (\"ipsum olora dsa\")\n"
+ "(\" dasd adas d\")";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}