const regex = /\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\("[^ ]*\\K\\h|(?!^)\\G[^" ]*\\K\\h', 'g')
const str = `Sit amet dolo lorem ("lorem ipsum do olor") dsa ("ipsum olora dsa")
(" dasd adas d")`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);