import Foundation
let pattern = #"\("[^ ]*\K\h|(?!^)\G[^" ]*\K\h"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Sit amet dolo lorem ("lorem ipsum do olor") dsa ("ipsum olora dsa")
(" dasd adas d")
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)