using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(""[^ ]*\K\h|(?!^)\G[^"" ]*\K\h";
string substitution = @"_";
string input = @"Sit amet dolo lorem (""lorem ipsum do olor"") dsa (""ipsum olora dsa"")
("" dasd adas d"")";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}