package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L`)
var str = `39983
"set x 1"
random_user
39984
"set x 45"
S0B0L
39985
"set x 23"
random_user`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}