$re = '/(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L/';
$str = '39983
"set x 1"
random_user
39984
"set x 45"
S0B0L
39985
"set x 23"
random_user';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);