use strict;
my $str = '39983
"set x 1"
random_user
39984
"set x 45"
S0B0L
39985
"set x 23"
random_user';
my $regex = qr/(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}