import Foundation
let pattern = #"(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
39983
"set x 1"
random_user
39984
"set x 45"
S0B0L
39985
"set x 23"
random_user
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}