re = /(?i)[0-9]+[\r\n]+.*[\r\n]+S0B0L/
str = '39983
"set x 1"
random_user
39984
"set x 45"
S0B0L
39985
"set x 23"
random_user'
# Print the match result
str.match(re) do |match|
puts match.to_s
end