using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s?([:[\()=$~|^$*,>+~]) ?";
string substitution = @"$1";
string input = @".class #id div, p div div > p [attribute $= value] a
: visited input:disabled p: nth-last-of-type( 2)
p [attribute]
p[attribute=value ]
div a [ attribute~=value ]
[attribute| =value]
[attribute^=value]
[attribute $=value]
[attribute*=value] ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}