package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s?([:[\()=$~|^$*,>+~]) ?`)
var str = `.class #id div, p div div > p [attribute $= value] a
: visited input:disabled p: nth-last-of-type( 2)
p [attribute]
p[attribute=value ]
div a [ attribute~=value ]
[attribute| =value]
[attribute^=value]
[attribute $=value]
[attribute*=value] `
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}