$re = '/\s?([:[\()=$~|^$*,>+~]) ?/';
$str = '.class #id div, p div div > p [attribute $= value] a
: visited input:disabled p: nth-last-of-type( 2)
p [attribute]
p[attribute=value ]
div a [ attribute~=value ]
[attribute| =value]
[attribute^=value]
[attribute $=value]
[attribute*=value] ';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;