import re
regex = re.compile(r"\s?([:[\()=$~|^$*,>+~]) ?")
test_str = (".class #id div, p div div > p [attribute $= value] a\n"
": visited input:disabled p: nth-last-of-type( 2)\n\n"
"p [attribute]\n"
"p[attribute=value ]\n"
"div a [ attribute~=value ]\n"
"[attribute| =value]\n"
"[attribute^=value] \n"
"[attribute $=value] \n"
"[attribute*=value] ")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)