# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/({matrix}.*? \\)( .*?(?={matrix}))/$1\\$2/gm;t' <<< "matrix \dfrac{ \left( \sqrt{ \left(\begin{matrix} 5 \\ \left(\begin{matrix} 66 \ 11 \end{matrix}\right) \ \end{matrix}\right) \phantom{\tiny{!}}} , \sqrt[ 6 ]{ 66 \phantom{\tiny{!}}} \right) }{ 6 } 5 \dfrac{ 22 }{ 5 }"