import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{matrix\\}.*? \\\\)( .*?(?=\\{matrix\\}))";
final String string = "matrix \\dfrac{ \\left( \\sqrt{ \\left(\\begin{matrix} 5 \\\\ \\left(\\begin{matrix} 66 \\ 11 \\end{matrix}\\right) \\ \\end{matrix}\\right) \\phantom{\\tiny{!}}} , \\sqrt[ 6 ]{ 66 \\phantom{\\tiny{!}}} \\right) }{ 6 } 5 \\dfrac{ 22 }{ 5 }";
final String subst = "$1\\\\$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}