const regex = /({matrix}.*? \\)( .*?(?={matrix}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({matrix}.*? \\\\)( .*?(?={matrix}))', 'gm')
const str = `matrix \\dfrac{ \\left( \\sqrt{ \\left(\\begin{matrix} 5 \\\\ \\left(\\begin{matrix} 66 \\ 11 \\end{matrix}\\right) \\ \\end{matrix}\\right) \\phantom{\\tiny{!}}} , \\sqrt[ 6 ]{ 66 \\phantom{\\tiny{!}}} \\right) }{ 6 } 5 \\dfrac{ 22 }{ 5 }`;
const subst = `$1\\$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);