using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"({matrix}.*? \\)( .*?(?={matrix}))";
string substitution = @"$1\\$2";
string input = @"matrix \dfrac{ \left( \sqrt{ \left(\begin{matrix} 5 \\ \left(\begin{matrix} 66 \ 11 \end{matrix}\right) \ \end{matrix}\right) \phantom{\tiny{!}}} , \sqrt[ 6 ]{ 66 \phantom{\tiny{!}}} \right) }{ 6 } 5 \dfrac{ 22 }{ 5 }";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}