import re
regex = re.compile(r"({matrix}.*? \\)( .*?(?={matrix}))", flags=re.MULTILINE)
test_str = "matrix \\dfrac{ \\left( \\sqrt{ \\left(\\begin{matrix} 5 \\\\ \\left(\\begin{matrix} 66 \\ 11 \\end{matrix}\\right) \\ \\end{matrix}\\right) \\phantom{\\tiny{!}}} , \\sqrt[ 6 ]{ 66 \\phantom{\\tiny{!}}} \\right) }{ 6 } 5 \\dfrac{ 22 }{ 5 }"
subst = "$1\\\\$2"
result = regex.sub(subst, test_str)
if result:
print(result)