using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$";
string input = @"1.160.10.240
192.001.32.47
1.2.3.
1.2.3
0.00.10.255
1.2.$.4
255.160.0.34
.1.1.1
1..1.1.1
1.1.1.-0
.1.1.+1
1 1 1 1
1
10.300.4.0
10.4F.10.99
fruit loops
1.2.3.4.5
0.0.0.0
0.0 0.0.
1.23..4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}