import re
regex = re.compile(r"^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$", flags=re.MULTILINE)
test_str = ("1.160.10.240\n"
"192.001.32.47\n"
"1.2.3.\n"
"1.2.3\n"
"0.00.10.255\n"
"1.2.$.4\n"
"255.160.0.34\n"
".1.1.1\n"
"1..1.1.1\n"
"1.1.1.-0\n"
".1.1.+1\n"
"1 1 1 1\n"
"1\n"
"10.300.4.0\n"
"10.4F.10.99\n"
"fruit loops\n"
"1.2.3.4.5\n"
"0.0.0.0\n"
"0.0 0.0.\n"
"1.23..4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")