$re = '/^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$/m';
$str = '1.160.10.240
192.001.32.47
1.2.3.
1.2.3
0.00.10.255
1.2.$.4
255.160.0.34
.1.1.1
1..1.1.1
1.1.1.-0
.1.1.+1
1 1 1 1
1
10.300.4.0
10.4F.10.99
fruit loops
1.2.3.4.5
0.0.0.0
0.0 0.0.
1.23..4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);