const regex = /^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((2(?!5?[6-9])|1|(?!0\\B))\\d\\d?\\.?\\b){4}$', 'gm')
const str = `1.160.10.240
192.001.32.47
1.2.3.
1.2.3
0.00.10.255
1.2.\$.4
255.160.0.34
.1.1.1
1..1.1.1
1.1.1.-0
.1.1.+1
1 1 1 1
1
10.300.4.0
10.4F.10.99
fruit loops
1.2.3.4.5
0.0.0.0
0.0 0.0.
1.23..4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}