import Foundation
let pattern = #"^((2(?!5?[6-9])|1|(?!0\B))\d\d?\.?\b){4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.160.10.240
192.001.32.47
1.2.3.
1.2.3
0.00.10.255
1.2.$.4
255.160.0.34
.1.1.1
1..1.1.1
1.1.1.-0
.1.1.+1
1 1 1 1
1
10.300.4.0
10.4F.10.99
fruit loops
1.2.3.4.5
0.0.0.0
0.0 0.0.
1.23..4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)