import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((2(?!5?[6-9])|1|(?!0\\B))\\d\\d?\\.?\\b){4}$";
final String string = "1.160.10.240\n"
+ "192.001.32.47\n"
+ "1.2.3.\n"
+ "1.2.3\n"
+ "0.00.10.255\n"
+ "1.2.$.4\n"
+ "255.160.0.34\n"
+ ".1.1.1\n"
+ "1..1.1.1\n"
+ "1.1.1.-0\n"
+ ".1.1.+1\n"
+ "1 1 1 1\n"
+ "1\n"
+ "10.300.4.0\n"
+ "10.4F.10.99\n"
+ "fruit loops\n"
+ "1.2.3.4.5\n"
+ "0.0.0.0\n"
+ "0.0 0.0.\n"
+ "1.23..4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}