#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$"
Local $sString = "lowercase name" & @CRLF & _
"Unicode NamĂȘ" & @CRLF & _
"A Name" & @CRLF & _
"not" & @CRLF & _
"McGeorge Bundy" & @CRLF & _
"Three Letters Name" & @CRLF & _
"Alfred McCoy Tyner" & @CRLF & _
"McCoy Tyner" & @CRLF & _
"Good Name" & @CRLF & _
"O'Keane Name" & @CRLF & _
"Inv4l1d N$m3" & @CRLF & _
"C00l name" & @CRLF & _
",Comma Name" & @CRLF & _
"Following Dot," & @CRLF & _
"Wrong' Quote" & @CRLF & _
"Wrong UpperCase" & @CRLF & _
"notCool Name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")