import re
regex = re.compile(r"^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$", flags=re.MULTILINE)
test_str = ("lowercase name\n"
"Unicode Namê\n"
"A Name\n"
"not\n"
"McGeorge Bundy\n"
"Three Letters Name\n"
"Alfred McCoy Tyner\n"
"McCoy Tyner\n"
"Good Name\n"
"O'Keane Name\n"
"Inv4l1d N$m3\n"
"C00l name\n"
",Comma Name\n"
"Following Dot,\n"
"Wrong' Quote\n"
"Wrong UpperCase\n"
"notCool Name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")