re = /^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$/m
str = 'lowercase name
Unicode Namê
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O\'Keane Name
Inv4l1d N$m3
C00l name
,Comma Name
Following Dot,
Wrong\' Quote
Wrong UpperCase
notCool Name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end