use strict;
my $str = 'lowercase name
Unicode Namê
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O\'Keane Name
Inv4l1d N$m3
C00l name
,Comma Name
Following Dot,
Wrong\' Quote
Wrong UpperCase
notCool Name';
my $regex = qr/^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}