package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$`)
var str = `lowercase name
Unicode Namê
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O'Keane Name
Inv4l1d N$m3
C00l name
,Comma Name
Following Dot,
Wrong' Quote
Wrong UpperCase
notCool Name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}