// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$").unwrap();
let string = "lowercase name
Unicode Namê
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O'Keane Name
Inv4l1d N$m3
C00l name
,Comma Name
Following Dot,
Wrong' Quote
Wrong UpperCase
notCool Name";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}