using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$";
string input = @"lowercase name
Unicode NamĂȘ
A Name
not
McGeorge Bundy
Three Letters Name
Alfred McCoy Tyner
McCoy Tyner
Good Name
O'Keane Name
Inv4l1d N$m3
C00l name
,Comma Name
Following Dot,
Wrong' Quote
Wrong UpperCase
notCool Name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}