import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z][a-z]*)?[A-Z][a-z]* [A-Z][a-z]*$";
final String string = "lowercase name\n"
+ "Unicode Namê\n"
+ "A Name\n"
+ "not\n"
+ "McGeorge Bundy\n"
+ "Three Letters Name\n"
+ "Alfred McCoy Tyner\n"
+ "McCoy Tyner\n"
+ "Good Name\n"
+ "O'Keane Name\n"
+ "Inv4l1d N$m3\n"
+ "C00l name\n"
+ ",Comma Name\n"
+ "Following Dot,\n"
+ "Wrong' Quote\n"
+ "Wrong UpperCase\n"
+ "notCool Name";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}