using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>";
string input = @"Account number: <<@Account.AccountNumber>>
<<@Am\hich\af1\dbch\af31505\loch\f1 ount>>
<<@Amount>>
<<Where: Phrase =\ @Value>>\<<hi>>\hi<<hi>>
<<\hich\af1\dbch\af31505\loch\f1 @Amount>>
<<@Amount\hich\af1\dbch\af31505\loch\f1 >>
<<Where: Column > Value>>
<<Where: Column\hich\af1\dbch\af31505\loch\f1 > Value>>
<<Where: Column > \hich\af1\dbch\af31505\loch\f1 Value>>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}