use strict;
my $str = 'Account number: <<@Account.AccountNumber>>
<<@Am\\hich\\af1\\dbch\\af31505\\loch\\f1 ount>>
<<@Amount>>
<<Where: Phrase =\\ @Value>>\\<<hi>>\\hi<<hi>>
<<\\hich\\af1\\dbch\\af31505\\loch\\f1 @Amount>>
<<@Amount\\hich\\af1\\dbch\\af31505\\loch\\f1 >>
<<Where: Column > Value>>
<<Where: Column\\hich\\af1\\dbch\\af31505\\loch\\f1 > Value>>
<<Where: Column > \\hich\\af1\\dbch\\af31505\\loch\\f1 Value>>
';
my $regex = qr/<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}