const regex = /<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<<(?>(?>[^\\\\>]*)(?>>(?!>))?)*+\\\\(?>(?>[^>]*)(?>>(?!>))?)++>>', 'g')
const str = `Account number: <<@Account.AccountNumber>>
<<@Am\\hich\\af1\\dbch\\af31505\\loch\\f1 ount>>
<<@Amount>>
<<Where: Phrase =\\ @Value>>\\<<hi>>\\hi<<hi>>
<<\\hich\\af1\\dbch\\af31505\\loch\\f1 @Amount>>
<<@Amount\\hich\\af1\\dbch\\af31505\\loch\\f1 >>
<<Where: Column > Value>>
<<Where: Column\\hich\\af1\\dbch\\af31505\\loch\\f1 > Value>>
<<Where: Column > \\hich\\af1\\dbch\\af31505\\loch\\f1 Value>>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}