import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<<(?>(?>[^\\\\>]*)(?>>(?!>))?)*+\\\\(?>(?>[^>]*)(?>>(?!>))?)++>>";
final String string = "Account number: <<@Account.AccountNumber>>\n"
+ "<<@Am\\hich\\af1\\dbch\\af31505\\loch\\f1 ount>>\n"
+ "<<@Amount>>\n"
+ "<<Where: Phrase =\\ @Value>>\\<<hi>>\\hi<<hi>> \n"
+ "<<\\hich\\af1\\dbch\\af31505\\loch\\f1 @Amount>>\n"
+ "<<@Amount\\hich\\af1\\dbch\\af31505\\loch\\f1 >>\n"
+ "<<Where: Column > Value>>\n"
+ "<<Where: Column\\hich\\af1\\dbch\\af31505\\loch\\f1 > Value>>\n"
+ "<<Where: Column > \\hich\\af1\\dbch\\af31505\\loch\\f1 Value>>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}