import Foundation
let pattern = #"<<(?>(?>[^\\>]*)(?>>(?!>))?)*+\\(?>(?>[^>]*)(?>>(?!>))?)++>>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Account number: <<@Account.AccountNumber>>
<<@Am\hich\af1\dbch\af31505\loch\f1 ount>>
<<@Amount>>
<<Where: Phrase =\ @Value>>\<<hi>>\hi<<hi>>
<<\hich\af1\dbch\af31505\loch\f1 @Amount>>
<<@Amount\hich\af1\dbch\af31505\loch\f1 >>
<<Where: Column > Value>>
<<Where: Column\hich\af1\dbch\af31505\loch\f1 > Value>>
<<Where: Column > \hich\af1\dbch\af31505\loch\f1 Value>>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)